The W8 forum Homepage
Forum Home Forum Home > Problems, Tips and Tricks About the W8 > Mechanics
  New Posts New Posts RSS Feed: waterpump...?
  FAQ FAQ  Forum Search   Register Register  Login Login

 Shoutbox  Your message
You must log in to shout!

waterpump...?

 Post Reply Post Reply
Author
Message
JayTheSnork View Drop Down
Admin
Admin


Joined: 20-Mar-2016
Location: Waterford, CT
Online Status: Offline
Posts: 140
  Quote JayTheSnork Quote  Post ReplyReply Direct Link To This Post Topic: waterpump...?
    Posted: 23-Mar-2018 at 01:52
I'm getting ready to replace the accessory belt, the accessory belt tensioner, and the counterbalance belt and tensioner. I'm considering replacing the waterpump while I am in there.

I'm looking for suggestions - to do so or leave it be? what has been everyone's experience with waterpumps on this engine?
Back to Top
orangeokie View Drop Down
Groupie
Groupie
Avatar

Joined: 13-Jul-2010
Location: Oklahoma City
Online Status: Offline
Posts: 99
  Quote orangeokie Quote  Post ReplyReply Direct Link To This Post Posted: 23-Mar-2018 at 02:44
Are you doing the work yourself? It would be a royal PITA to have to go back in there to replace the water pump later. But if you are doing the work yourself, its just time.
Back to Top
JayTheSnork View Drop Down
Admin
Admin


Joined: 20-Mar-2016
Location: Waterford, CT
Online Status: Offline
Posts: 140
  Quote JayTheSnork Quote  Post ReplyReply Direct Link To This Post Posted: 23-Mar-2018 at 03:31
yes, and that's what I was thinking. just turned 90k, so I am trying to take care of some stuff prophylactically, in advance.
Back to Top
eddycooper View Drop Down
Groupie
Groupie


Joined: 24-Aug-2014
Online Status: Offline
Posts: 67
  Quote eddycooper Quote  Post ReplyReply Direct Link To This Post Posted: 01-Apr-2018 at 18:10
I did my water pump when I did my balance shaft belt. It was quiet and not leaking but when I pulled the pump out the bearing was definitely a bit loose. My car had 250k kms when I did it. It was an easy job with the accessory belt off. Have a look at the fasteners and make sure you've got the right tools. They're triple square and it's a bit tight in there with surrounding plumbing.

I found two part numbers for the pump:
07D121008A - appears to be a "new" part.
07D121008AX - the 'X' usually means a rebuilt part. This one is cheaper.

I bought the 'X' part and to me it looked brand new and identical to the pictures of the non-X part on ECSTuning.

A couple notes on the balance shaft belt job:
- when I did mine, the black plastic cover had been hit by debris from the belt snapping and it was broken - almost in two pieces. I replaced it. Hopefully you don't have the same problem.
- The part number for the harmonic balancer bolt is N10139802. There is another thread on here that incorrectly reported this part number.
- Buy a new balance shaft belt tensioner. Mine was still fairly smooth but the bearing had lost its oil/grease.
- Replace the accessory belt idlers. One of mine was bad and one was still good. Part number 07D145276C - OEM supplier is INA. I got mine at FCP Euro because they were much cheaper than OEM.
- Your call on the accessory belt tensioner. It's expensive. Mine was still good, thankfully. It's also relatively easy to replace later if it goes bad.
- I used 3L of coolant and 3L of water to refill the system after doing the water pump (6L total).

Good luck!
Back to Top
JayTheSnork View Drop Down
Admin
Admin


Joined: 20-Mar-2016
Location: Waterford, CT
Online Status: Offline
Posts: 140
  Quote JayTheSnork Quote  Post ReplyReply Direct Link To This Post Posted: 02-Apr-2018 at 02:41
how many accessory belt idlers are there, eddy? you seem to indicate there is more than one?
Back to Top
eddycooper View Drop Down
Groupie
Groupie


Joined: 24-Aug-2014
Online Status: Offline
Posts: 67
  Quote eddycooper Quote  Post ReplyReply Direct Link To This Post Posted: 02-Apr-2018 at 16:26
Two accessory belt idlers, plus the tensioner assembly.
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down

Bulletin Board Software by Web Wiz Forums® version 9.56a
Copyright ©2001-2009 Web Wiz

This page was generated in 0,059 seconds.